安装

系统需求和版本

backtrader 没有任何依赖包(需要绘图除外)

基本需求:

  • Python 2.7
  • Python 3.2/3.3/3.4/3.5
  • pypy/pypy3

如果需要绘图:

  • Matplotlib >= 1.4.1

    之前的版本也许也可以运行,但在开发中用了较新的版本。

Note

截至目前为止,Matplotlib 与 pypy/pypy3 尚未兼容

Python 2.x/3.x 兼容性

开发同时使用了 Python 2.7 和 Python 3.4。框架在这两个版本下测试通过。

与 3.2/3.3/3.5 和 pypy/pyp3 的兼容性,由 Travis 的持续集成来测试。

从 pypi 安装

使用 pip 安装:

pip install backtrader

也可以使用 easy_install 以相同的命令安装。

从 pypi 安装(包括 matplotlib)

如果还希望使用绘图功能,则可这样安装:

pip install backtrader[plotting]

这将会安装 matplotlib 和依赖的其他包。

当然也可以选择使用 easy_install 安装。

从源代码安装

首先下载源代码压缩包:

解压之后运行:

python setup.py install

直接将源代码拷贝到工程目录

下载源代码压缩包:

backtrader 包目录拷贝至你的项目中。在类Unix系统,命令如下:

tar xzf backgrader.tgz
cd backtrader
cp -r backtrader project_directory

记住如果需要绘图的话,需要手动安装 matplotlib